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VCarve Pro  

Disclaimer  

 

All CNC machines (routing, engraving, and milling) are potentially dangerous and because Vectric Ltd has no 
control over how the software described in this manual might be used. Vectric Ltd or any associated Resellers 
cannot accept responsibility for any loss or damage to the work piece, machine or any individual, howsoever 
caused by misusing the software. Extreme care should always be taken and the output from the software 
thoroughly checked before sending it to a CNC machine. 

The information in this manual may be subject to change without any prior notice. The software described in 
this manual is supplied under the terms and conditions of the software license agreement and may only be 
used in accordance with the terms of this agreement. 
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Introduction  

After releasing VCarve Pro version 4.5 in November 2007 customers told us they didnõt like the way the new 
2D toolpath previews worked when opening files. As this was annoying users we decided it needed fixing and 
while doing this work we also decided to enhance the profile and pocketing toolpath functionality. More 
details can be found in this document. 

VCarve Pro 4.5 included new layout and preview functionality that made designing and laying out projects 
much quicker, easier and more precise. New 2D Toolpath Preview options were also added to  make toolpath 
verification significantly easier by instantly showing exactly where toolpaths will machine and where material 
will be left on the job. 

Installation  

Vectric will email you a link for you to download an Upgrade File that will install VCarve Pro version 4.6. 

Click the Run button and the patch program will automatically detect and install the upgrade into your current 
VCarve Pro 4.0 or 4.5 folder structure. 

Note  If you have NOT  installed the software in a folder C:\ Program Files\ VCarve Pro 4.0  
  please contact the Vectric Support Team and additional instructions will be provided. 

 

The Upgrade program will retain the Tool Database from your VCarve Pro 4.5 installation, so any additional / 
custom tools that have been added will also be available in version 4.6. 

If you experience any difficulties or require assistance please e-mail - support@vectric.com 

 

Important After installing the update to version 4.6 please check that the correct postprocessor is  
  selected from the pull-down list on the Save Toolpaths form. 

 
 
Backing Up the Tool Database 
 

We recommend keeping a safe / backup copy of your Tool Database and this is done by taking a copy of the 
file saved in the folder shown below. 

C:\ Program Files\ VCarve Pro 4.5\ ToolDatabase\ tools.tool_db 

 

If you need assistance with this e-mail - support@vectric.com 

 

mailto:support@vectric.com
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Whatõs New in Version 4.6  

After releasing VCarve Pro 4.5 a couple of usability issues surfaced that were primarily related to how the 
toolpath list and 2D / 3D visibility behaved when opening saved files. This behaviour was annoying so we 
decided to fix it and version 4.6 now remembers the visibility state when opening files. 

While updating this behaviour we decided to take the opportunity to develop additional Profile and Pocket 
machining functionality that makes the software even more powerful and flexible. A summary of the new 
functionality in version 4.6 + the new features added in version 4.5 is listed below. 

Offset Open Vectors 
Open vectors / shapes can now be offset using the design tools in version 4.6. The new offset is created either 
to the Left or the Right of the selection using the start node as a reference to decide which is the correct side. 

     

 

Note Pressing N for Node Editing mode shows a Green square for the start node. Looking along the 
 selection from this point allows the Left and Right side to be determined. 

  

Toolpath Visibility 
In previous versions of VCarve Pro all toolpaths were automatically made visible in the 3D view when a file 
was opened, but this behaviour became a problem with version 4.5 because all associated 2D previews were 
also displayed. This resulted in users having to undraw many of their toolpaths before working on a project, 
which we felt was unacceptable software behaviour so this has been addressed in version 4.6. 

When new toolpaths were calculated in version 4.5 the 2D preview would always be made visible and drawn in 
the 2D window, and this was also reported by customers to be annoying behaviour.  

VCarve Pro 4.6 saves the visibility state for toolpaths so when a file is re-opened it behaves in the same way. 
And the 2D previews are only displayed if the option - Show 2D Previews is switched on 

 
Profile Machining Enhancements (4.6) 
The Profile Machining toolpath strategy has been enhanced to include new options for, 

Adding Tabs when machining On open and closed shapes 
Machining to the Left or Right of Open vectors and including Tabs with Ramp moves 

Left 

Right 

Start 
Node 
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This option to automatically compensate for the cutter radius on the Left or Right side of shapes is perfect for 
projects such as head-boards, where a curved profile maybe needed across the top of a sheet of material 
without cutting around the complete shape. 

When Profile machining On selected vectors the Cut Direction now controls whether the cutter starts at the 
start node or at the opposite end of open shapes. 

 Conventional cutting along an Open shape starts at the start point 
 Climb cutting along an Open shape starts at the End point and cuts back to the start point. 

Pocket Machining Enhancements (4.6) 
A totally new Pocket Machining strategy has been developed for version 4.6 that allows stopovers greater than 
50% to be used. When stepovers greater than 50% are used small ôTailsõ (see images below) are automatically 
added to corner regions of toolpaths. The ôTailsõ ensure the cutter removes all unwanted material as quickly as 
possible and typically reduces cutting times by at least 20% - 30%. 

   

        2D Toolpath Preview            3D view showing Toolpath ôTailsõ 

The Tails are automatically added to Pocket and Flat Bottom VCarving / Engraving toolpaths. 
 
Pocket machining toolpaths were previously limited to a maximum stepover of 50% of the cutter 
diameter, to ensure material was not left in corner regions on projects. This resulted in unnecessarily 
long machining times when machining soft materials. 
 
It is important to note that stepover distance is often controlled by the material being machined and the 
type of cutter being used. Hard / Tough materials usually require smaller stopovers whereas softer 
materials can often take advantage of the larger stopovers available in VCarve Pro 4.6. 

 
Miscellaneous Enhancements 
The option to send toolpaths directly to Mach3 (version 2.61 or newer) has been added in 4.6. This saves 
having to keep opening the toolpaths in Mach3. The Mach3 postpõs now include the Direct output option. 

When opening or importing PDF documents that contain multiple pages - Word processor / design 
documents, new layers are automatically created for each page in the file. Previously all pages were created on a 
single layer making it very difficult to work with these types of files. 

When exporting DXF files the correct units (Inches / Metric) are now written into the file. 

For a list of the bug-fixes in version 4.6 see the Readme.txt file. 

Tails 
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Whatõs New in Version 4.5  

The new tools in VCarve Pro 4.5 have been added to make designing and laying out projects much easier, 
quicker and more precise. Most of the new functionality is found in the 2D window where tools such as 
Rulers and Guide Lines plus accurate Snapping options are perfect for accurate drawing and object placement. 

The high quality Toolpath Preview has been enhanced to show the toolpaths in the 2D Window and see 
instantly what the toolpaths will and wonõt actually cut.  

New Toolpath Preview Options  

Although the high quality colour shaded 3D Toolpath preview options in VCarve Pro give fantastic results 
that are perfect for printing and customer approvals etc. It can sometimes be difficult to determine whether a 
toolpath is cutting Outside / Inside / On a line.  

The New 2D Preview options show exactly where toolpaths will cut relative to the vectors. The 2D preview 
can be selected to draw the vector lines to represent the centre point of the cutter or to show in solid colour 
the complete area that the cutter represents relative to the vectors. This shows where the cutter will leave 
material on the job ð for example leaving fillets in corners that the cutter cannot get into. 

2D Wireframe Toolpath Preview  
The Wireframe 2D Toolpath shows arrows to indicate the cutting direction and can be used to preview all 
calculated toolpaths in the 2D window. 

  

 Raster Pocket Toolpath    Offset Pocket Toolpath 

2D Solid Toolpath Preview 
The solid 2D Toolpath preview shows exactly where material will be removed and instantly shows where 
material will be left because the cutter is too large to fit through the selected vectors. 

 

Wireframe Preview for 
Engraving / VCarving 

Toolpath 
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The visibility of 2D toolpath previews is controlled using the Toolpath List Manager to display or hide any 
calculated toolpaths in the 3D window. 

 

 

Auto Open 3D View 
A new option has been added that enables the 2D view to remain open after calculating toolpaths, instead of 
automatically opening the 3D view, which is the way previous versions of the software behaved. This is quite 
useful for experienced users who may be calculating multiple toolpaths and donõt always wish to keep the 3D 
view. 

 

 

Solid Wireframe 

Solid Preview shows 
where the cutter radius 
is to large to completely 

machine the letters. 
 

Also shows where the 
tip radius will leave 
material in corner 

regions 
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New Design and Layout Tools 
Additional layout and drawing tools have been added to the Drawing Tab on the Left side of the interface and 
this document explains what these enhancements are. 

2D View 
Rulers, Guide Lines, a Snap Grid and Toolpath Previews are now all available in the 2D View  

Rulers 
Horizontal and Vertical Rulers have been added to the 2D window that give immediate view of the job 
size and make it much easier to layout designs. 
 
Zooming in / out changes the unit values displayed on the rulers with units in 10ths. 
 

10ó > 1ó > 0.1ó > 0.01ó > 0.001ó 
 
100mm > 10mm > 1mm > 0.1mm 
 

 

Rulers and Guide Lines make drawing shapes much easier 

 

 

 

Rulers 

Guide Lines 
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Guidelines 
Guide Lines make sketching designs quick and easy and are also very useful for drawing and aligning 
objects relative to each other. 
 
Guidelines are added by Clicking and dragging (left mouse button) a guide off the rulers. The position 
of the Guide Line is displayed next to the cursor while dragging it to the required position. 
 

 
 
The guides automatically snap to the whole units displayed on the ruler making it very easy to position a 
guide at the required location. 
 
To show or hide the Guide Lines in the 2D window click in the Top Left corner of the window where 
the vertical and horizontal rulers meet. 
 

 
 
 
 
Guide lines are deleted by clicking and dragging each guide line off the 2D window back onto the rulers. 
 
All Guide lines can be deleted using the Main Menu option, 
 

View > Guide Lines > Delete All Guides 
 
To Move, Delete, Lock or Add more Guide Lines place cursor over the guide and click the, 
 

 Right mouse button 
 

Click and 
Drag 

Click here to 
toggle the 

visibility of Guide 
Lines 
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The Guide Properties menu is displayed giving options to, 
 
 Delete the selected guide  

Move the guide it to a new position 
Lock the guide in position to stop it being accidentally moved 
Add additional Guide lines at Absolute positions or at an incremental distance 

 
Guide Lines can also be added interactively relative to an existing Guide by, 
 
 Holding the Ctrl key and Click and drag, moving the new guide to the required position 
 The incremental distance from the original guide is shown next to the cursor 
 Releasing the Ctrl key while dragging to position a guide displays the absolute position 

 
Snap Grid 
A Snap Grid can now be added to the 2D window to help when drawing and laying out designs. The 
Snap Grid is switched on / off and the grid size specified by, 
 
  Pressing F4  

Selecting Edit > Snap Options 
 
When drawing or moving objects the default mode is to snap to the grid points. 
 
Snapping can be overridden / temporarily disabled by holding the Shift key  
 

Snapping Options 
The new snapping options automatically work when drawing shapes or positioning objects. The cursor 
changes to show the various snap options. 
When drawing the cursor will snap to, 
 
 End points, Mid-points, Arc centers and centers of objects 
 Horizontally, Vertically and the specified Angle and Distance 
 Guide lines and the intersection of Guides 
 
Snapping can be overridden / temporarily disabled by holding the Shift key  

Create new  
Guide Lines 

Position / Delete / Lock 
Guide Lines 
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The Snapping Settings can be configured using the by Pressing F4 or selecting Edit > Snap Options 
 

 
 
Drawing Tab 
The drawing tools have been updated with new icons for the new functionality. 

  

Draw 
Star & Polygon  

Fillet Corners  


