Frequently Asked Questions

Getting started with Vectric software is easy and seamless.

What topic are you looking for information on?

Can't find what you are looking for?
We would like to chat with you.

Contact Support

Software

Details of the system requirements needed for all of Vectric's software packages can be found here.

However, we would strongly advise downloading our free trial software to ensure you choose the software that is right for you. You can also test the software on your CNC machine by cutting one of our free trial projects.

To download the free trial click here

Start the program and use File > Open Application Data Folder. This will open a new window showing all the program's support folders. Select the Tool Database folder to find the Tool Database file.

Start the program and use File > Open Application Data Folder. This will open a new window showing all the program's support folders. Select the Post Processor folder to find the Post Processors.

Gadgets are only available in our VCarve Pro & Aspire software packages.

A gadget is an external add-in program that performs a specific task. New gadgets are simply copied to the "gadgets" folder (one of the application data folders) and when the program is restarted, they will be available from the gadgets menu.

The program is shipped with a number of gadgets and more may be made available from the Vectric web site over time.

Click here to find more information about Gadgets.

Start the program and use File > Open Application Data Folder. This will open a new window showing all the program's support folders. Select the Gadgets folder to find the Gadgets.

On installation, all Vectric products will create a listing in the Windows programs and features control panel applet ('Add or Remove Programs' in older versions of Windows).

Windows 8, 8.1, 10 or 11

  1. Open the Windows start menu (Windows key). From the "Start" screen, start typing "Control Panel" (the search should autofill after a few characters).
  2. Click on "Control Panel" from the Apps search results, in the opened "Control Panel" window, select "Programs and Features"
  3. In the "Programs and Features" window, you will see the Vectric product listed amongst the other applications installed on your computer. Select the Vectric application that you wish to uninstall and click on the "Uninstall" button.

Windows 7

  1. Open the Windows Start menu (Windows Key). From the "Start" click on "Control Panel"
  2. Depending on your view options click either on "Uninstall a program" or "Programs and Features"
  3. In the "Programs and Features" window, you will see the Vectric product listed amongst the other applications installed on your computer. Select the Vectric application that you wish to uninstall and click on the "Uninstall" button.

From the main menu bar along the top of the screen, select Help > About <program name> where <program name> is the program you are using.

From Aspire 4 / VCarve Pro 7 onwards you can add new images to the Material Images folder in your Vectric Files folder.

In Aspire 3.5 / VCarve Pro 6.5 or earlier you will need start the program and use File > Open Application Data Folder. This will open a new window showing all the program's support folders. You can add new material image files to the Bitmap Textures folder.

You will need to restart the software for your new image files to appear in the material drop-down lists.

The file you are trying to open has either been deleted or moved to another location on your computer.

Click OK, and use "Open an existing file" to manually locate your file.

Errors when saving across a network is likely caused by minor faults in a network connection.

It is more reliable to work from the local drive, and less likely to result in lost or corrupted files.

Should you encounter this error when saving, save your projects to a local destination and then back them up to your network accessed storage once completed.

Licensing

Yes – from day one you will own the software outright. In addition, unlike most software companies Vectric allow you to transfer your licence to another user if you sell your CNC machine subject to a small licence transfer fee.

Our software has been designed to be intuitive and easy to use regardless of your experience level. We encourage everyone to download our free trial software to be sure it's right for you before you purchase. You can also access all of our video tutorials under the 'support' section of our website or on our YouTube channel.

Vectric's license allows any of our software programs to be installed on up to 3 PC's for a single user.

If access to any one of the computers is shared with work colleagues, or anyone who is likely to access the software, then the software must only be installed onto one computer.

We have many users who have the software installed on their main design pc, the computer attached to their CNC and a laptop. As long as these three systems are only used by the same single user, this is completely legal.

Minor updates are always free to anyone who has the same major version (e.g V12.5 will be free to all owners of V12 software).

Any major version of the software released within 12 months of you purchasing the software is supplied free of charge and available from your V&Co account.

You can upgrade to the latest version of the software for the same price, regardless of the version you are currently running. For example, the price to upgrade to the latest version of the software is the same, regardless of whether you are upgrading from version 4.0 or 11.0.

If you upgrade your software to a new version (not a new product purchase) you will get a bonus 3 months FREE upgrade period (as a 'safety net' in case Vectric release another version within 3 months of your most recent upgrade purchase)

The upgrade eligibility timescales are as follows:

  • If you have purchased a brand new product for the first time - You will receive FREE upgrades to any new versions released within 12 months of your purchase date.
  • For upgrading to a new product - for example from VCarve Pro to Aspire - You will receive FREE upgrades to any new versions released within 12 months of the date you upgraded to Aspire. 
  • For upgrading from one version to another for example from VCarve Pro V9 to VCarve Pro version 12 - You will receive a FREE upgrade to any new version of VCarve Pro released within 3 months of you purchasing the upgrade. 

No – you are never forced to upgrade your software.

If a new version is released within the first 12 months of ownership, you get the upgrade for free. If you are outside of this period. you can evaluate the new features by downloading the FREE trial to decide if you would like to upgrade and take advantage of the new features and enhancements.

For your personalised upgrade options and pricing please head over to your V&CO account.

We don't penalize you for not updating your software with every release. The cost to update your software to the latest version of the same product is the same regardless of which version you are updating from.

If you would like to upgrade to a more advanced product for example VCarve Desktop to VCarve Pro you can do this by just paying the difference between the two products.

For all of your personalized upgrade options simply head over to your V&CO account.

Our educational license is designed to be used in a single classroom environment where up to 40 pupils need to get access to use the software as well as the tutor. The price of a multi-user educational license is the same as a standard single user license. You can find all of our product pricing here.

The terms for an educational license are as follows:

  • Can be installed on up to 40 computers in one single classroom.
  • Cannot be installed on students individual or personal laptops.
  • Can be installed on one teachers laptop, which may be used outside of the classroom.
  • License must be registered to an individual school rather than a school district.
  • License must be registered using an email address belonging to the school or university.
  • An educational classroom license is non-transferable.

For more information on our educational license click here.

Unlike most software companies, Vectric does allow the original purchaser of a software licence to transfer it under certain circumstances, and subject to a licence transfer fee. However this is NOT an unrestricted right of transfer, and Vectric reserve the right to refuse to transfer the licence, at its sole discretion, if it reasonably believes there is evidence of the license conditions having been broken. If you upgrade a product from say version 4.0 to version 5.0, you no longer have a valid licence for version 4.0 and so the licence for the older version obviously cannot be transferred.

Software licence purchased directly from Vectric or an authorised Vectric partner

If you have purchased a single user license directly from Vectric or one of our authorised partners, we would usually allow you to transfer the single user license to another individual or company, subject to the licence conditions having been adhered to and the payment of a licence transfer fee (currently $50).

You cannot transfer a license that you have not directly purchased (i.e. one that has been transferred to you, from a previous licence holder). The original purchaser of the software licence can transfer it once, but subsequent owners cannot.

If you upgrade a product to a more expensive one, you cannot subsequently transfer the initial product licence. e.g. if you upgrade VCarve Pro to Aspire, the VCarve Pro licence has been 'traded in' against the Aspire licence and you no longer have a licence for VCarve Pro.

Software licence transferred from a previous original owner

If you have obtained a licence from a previous original owner, you cannot subsequently transfer that licence to a new owner, unless the software licence was originally bundled with a machine, and you are transferring the machine along with the licence (see section below for this case). The transfer rights for the software are only available to the original purchaser of the software from Vectric or one of our authorised partners. If you are planning to buy a 'used' licence of Vectric software from somebody, it is essential that you contact Vectric first via sales@vectric.com to ensure that the licence in question can be transferred.

Software licence originally bundled with a machine tool

If you received Vectric software bundled with a machine tool from an approved Vectric partner, you may transfer the software along with that machine tool, providing that you have not used the license to upgrade to a different product. This applies even if you are not the original purchaser of the machine.

If you have upgraded the software, the upgraded product would need to be transferred along with the original media supplied with the machine. You do NOT have to transfer the software licence when you sell the machine, but the new owner of the machine will need to purchase their own copy of the software if they wish to use it in this case.

Educational Software Licence

Educational classroom licenses cannot be transferred.

Please email details of any license transfer requests to sales@vectric.com

Our free trial software will let you use all functions within the software except for saving the toolpaths and performing some export functions.

The Pro versions of the trials also do not allow you to use additional gadgets.

There are a collection of special free trial files made available for each program that are setup so you can save the toolpaths from them and verify compatibility with your CNC machine by actually machining the free trial projects. There free trial projects can be found here.

PhotoVCarve can work with any photo image however restricts the toolpath output by applying a watermark to all images.

All Vectric software products, including trial versions will run on virtually any PC's and do not require any special hardware or graphics cards. You should keep in mind that a higher specification will give you better performance. Also with the addition of a dedicated graphics card you will see even better performance with regards to the 3D view, toolpath previews and overall performance.

  • Aspire, VCarve Pro and VCarve Desktop - 2 Ghz Multi-Core X86 or x64 CPU, 4Gb RAM, 1GB Disk space, Windows 7, 8, 8.1, 10 or 11
  • Cut2D Pro & Cut2D Desktop - 2 Ghz Multi-Core X86 or x64 CPU, 2Gb RAM, 700 Mb Disk space, Windows 7, 8, 8.1, 10 or 11
  • Cut3D & PhotoVCarve - 1 GHz Pentium 4, 512 Mb RAM, 60 Mb Free disk space, Windows 7, 8, 8.1, 10 or 11

Optional Minimum Graphics Card Requirements – 2 GBs of dedicated RAM and OpenGL 3.3 as a minimum or later. Note: Vectric software can be run with CPU rendering as fallback.

To see a full list of minimum requirements, head over to our system requirements page here.

Vectric software is designed specifically to be used with 3-Axis CNC machines and has not been optimized for use with a plasma or water jet machine, however some users have successfully used it to operate this type of equipment.

Aspire 4.0, VCarve 7.0 and higher include an option to add plasma loops onto acute corners of toolpaths.

We would recommend looking closely at the options available in the trial version of each program before specifically purchasing them for use with these types of machines. Another good source of information on how the software has been used successfully is to search the main Forum.

Cut2D and PhotoVCarve do not support tool changers.

Cut3D, VCarve Pro and Aspire all support Tool Changers assuming you have the correct post processor selected.

You can confirm this for your CNC machine by downloading the Trial Versions, opening the included sample projects, and saving the toolpaths with the correct Tool Changer post processor for your machine. Then you can cut samples at your machine and confirm correct tool changer operation.

Makerspace

The Makerspace Edition will be licensed on an annual basis for a fee of US$99 per year for qualifying Makerspaces. This license fee will entitle the Makerspace to install the software on up to 5 machines located at the Makerspace and all upgrades to the software are free during the 12 month period. We have adopted this license model to ensure that we can keep the Makerspace software up to date at all times to ensure compatibility with the Makerspace Client Edition.

The license agreement for the Makerspace Edition only allows licensed makerspace users to load files from the Makerspace Client Edition for cutting on CNC machines at the licensed makerspace, it is expressly forbidden to generate toolpaths from a Makerspace Client file for use on CNC machines not present at the Makerspace premises. The Makerspace Edition of the software must only be installed at the Makerspace location. If these conditions are violated, the VCarve Pro Makerspace license will be revoked.

The Makerspace Edition will be licensed on an annual basis for a fee of US$99 per year for qualifying Makerspaces. This license fee will entitle the Makerspace to install the software on up to 5 machines located at the Makerspace and all upgrades to the software are free during the 12 month period. We have adopted this license model to ensure that we can keep the Makerspace software up to date at all times to ensure compatibility with the Makerspace Client Edition.

The license agreement for the Makerspace Edition only allows licensed makerspace users to load files from the Makerspace Client Edition for cutting on CNC machines at the licensed makerspace, it is expressly forbidden to generate toolpaths from a Makerspace Client file for use on CNC machines not present at the Makerspace premises. The Makerspace Edition of the software must only be installed at the Makerspace location. If these conditions are violated, the VCarve Pro Makerspace license will be revoked.

The Makerspace Edition will be licensed on an annual basis for a fee of US$99 per year for qualifying Makerspaces. This license fee will entitle the Makerspace to install the software on up to 5 machines located at the Makerspace and all upgrades to the software are free during the 12 month period. We have adopted this license model to ensure that we can keep the Makerspace software up to date at all times to ensure compatibility with the Makerspace Client Edition.

The license agreement for the Makerspace Edition only allows licensed makerspace users to load files from the Makerspace Client Edition for cutting on CNC machines at the licensed makerspace, it is expressly forbidden to generate toolpaths from a Makerspace Client file for use on CNC machines not present at the Makerspace premises. The Makerspace Edition of the software must only be installed at the Makerspace location. If these conditions are violated, the VCarve Pro Makerspace license will be revoked.

Once the purchase of the Makerspace Edition is complete and the makerspace's organization is set up within V&Co, you can easily download the software directly from the V&Co platform. Follow the steps below to access and download the Makerspace Edition:

  1. Visit the V&Co website at https://portal.vectric.com.
  2. Log in to your V&Co account using your credentials associated with the makerspace organization.
  3. Upon successful login, navigate to the organization's dashboard or the designated section for software downloads.
  4. Look for the Makerspace Edition software in the list of available downloads.
  5. Click on the download link or button associated with the Makerspace Edition software.
  6. The software installer file will be downloaded to your computer.

Once the software installer file is downloaded, you can proceed with the installation process following the provided instructions. After installation, you will be ready to access the Makerspace Edition software and begin using its features and tools within your makerspace.

To set up the Makerspace Edition software at your makerspace, follow the steps below. This process involves logging in with your makerspace account and registering the device:

  1. Launch the Makerspace Edition software on the device you want to set up at the makerspace.
  2. If prompted, click on the "Login" button to initiate the login process.
  3. Your default web browser will open and redirect you to the makerspace login page.
  4. Enter your registered makerspace account credentials (username and password) on the login page.
  5. Follow the instructions provided on the login page to complete the login process.
  6. After successful login, return to the Makerspace Edition software.

The Makerspace Edition of VCarve Pro provides members of a participating makerspace with access to Vectric's powerful software for designing and creating projects. Here's a breakdown of how it works:

  1. What is VCarve Pro Makerspace Edition? VCarve Pro Makerspace Edition is a version of Vectric's VCarve Pro software specifically designed for makerspaces. It grants makerspace members the ability to use VCarve Pro's advanced features and tools for their projects.
  2. Membership Registration: Makerspace members need to register with your makerspace to access the benefits of the Makerspace Edition. Registration allows members to log in to a trial edition of VCarve Pro.
  3. Trial Edition Login and Design Creation: Once registered, makerspace members can log in to the trial edition of VCarve Pro. The trial edition provides access to the comprehensive design capabilities of VCarve Pro. Members can use the software to create intricate and detailed designs for their projects.
  4. Creating Projects at the Makerspace: With their designs ready, makerspace members can bring their projects to the physical makerspace. At the makerspace, members can use the on-site machines and tools to fabricate their designs.

The Makerspace Edition empowers makerspace members to unleash their creativity and turn their design ideas into tangible projects using VCarve Pro's versatile features. By combining the software's capabilities with the resources available at the makerspace, members can bring their visions to life.

To become a member of the makerspace and gain access to the Makerspace Edition software, follow the registration process outlined below:

  1. Contact the makerspace administrator or designated contact person to express your interest in becoming a member.
  2. The administrator will provide you with the necessary information and instructions for registration. If required, the administrator may send you a registration link that you can use to sign up. Alternatively, they may invite you via email.
  3. Follow the instructions provided by following the shared link or the received email.
  4. Provide the requested information, which may include your name, email address, and any additional details required by the makerspace.
  5. If necessary, review and agree to the terms and conditions of the makerspace.
  6. Submit the registration form or complete the registration process as guided by the administrator.

Once your registration is confirmed by the makerspace administrator, you will become an official member of the makerspace.

To access the trial edition of VCarve Pro and utilize its features, follow the steps below:

  1. Head over to https://www.vectric.com/free-trial to download the free trial version of VCarve Pro.
  2. Launch the trial edition of VCarve Pro on your computer.
  3. On start-up, the software will automatically open your default web browser and redirect you to the login page.
  4. In the web browser, enter your registered email address associated with your makerspace membership.
  5. Click the "Login" or "Sign In" button on the login page to initiate the login process.
  6. If necessary, follow any additional instructions presented in the browser to complete the login process.
  7. Once the login is successful, you will be redirected back to the trial edition of VCarve Pro.

After logging in, you will have access to the trial edition of VCarve Pro, where you can explore its tools and features to design and create your projects.

To bring your designs to life and machine them at the makerspace, follow the steps below:

  1. Save your design file from the trial edition of VCarve Pro onto a portable storage device (e.g., USB flash drive, external hard drive).
  2. Take the saved design file to the makerspace along with the portable storage device.
  3. Log in to VCarve Pro Makerspace Edition using the machine's login prompt
  4. Once logged in, navigate to the section in the software where you can open and load design files.
  5. Select the saved design file from your portable storage device and open it within the Makerspace Edition.
  6. Review the design settings, toolpaths, and machining parameters to ensure they are appropriate for your desired outcome.
  7. Set up the machine and material according to the instructions provided by the makerspace or the machine manufacturer.
  8. Proceed with the machining process, following safety guidelines and any additional instructions specific to the makerspace or the machine being used.

By following these steps, you can machine the designs you created using the Makerspace Edition at the makerspace.

If you have any questions or encounter any difficulties during the machining process, consult the makerspace staff or administrators for assistance and guidance.

SketchUp

For Aspire 3D components: Once you have a new project opened, or an existing project opened, Use File > Import > Import Component/3D Model.

For VCarve Pro and Aspire Vectors: Once you have a new project opened, or an existing project opened, Use File > Import > Import Vectors...

This will allow you to select your desired .SKP file and load the Sketchup File Import window.

From here you have various options to modify how the 3D Model is turned into 2D Vector lines that can be used in the software.

You can also use the Windows Drag and Drop to drop a .SKP file directly onto an opened projects 2D View which will begin the import process.

If possible, take your Sketchup design and lay out the components flat with the pieces orientated as if you were laying them out to cut. This will ensure that when they are imported, the vectors are exactly where you want them to be.

When working with layers it is important to ensure that all parts of the element you are working with exist on the correct layer.

Due to the nature of Sketchup’s layers system, it is easy to spread a model over multiple layers, which will make importing it more difficult.

Most 3D packages apply a visual smoothing that makes a 3D model appear to be smoother than it really is.

Aspire will only show a 3D model as it really is, with no smoothing applied. This is to ensure that the on-screen representation correctly resembles the final cut piece.

Once your 3D model is in Aspire, you can use the smooth components tool to take some of the edges off your model, but it is more effective to increase the polygon count within your 3D package and reimport it.

Check that you are using the same scale in both Aspire and SketchUp. If you use mm in one and Inch in another, this can cause confusion when you are importing to Aspire.

The only time you can change the measurements for SketchUp is to change the template option when first opening the software.

When importing a model for vectors, any component attached to multiple layers will be imported multiple times.

To stop this, select "Only import visible data on selected layers" and deselect all layers except for one instance of each component.

2D vectors cannot record something from a 3D image, either use the 3D component import function, or approximate the desired curvature of your edge using a profile tool path combined with a round over tool bit.

If your material and tool bit settings are accurate to your equipment, the toolpath preview will accurately show you the final effect if there is no requirement for an undercut.

Undercuts cannot be viewed in Aspire or VCarve Pro.

Aspire V4.5+ and VCarve V7.5+ can read Native SketchUp format (.SKP). Load them from File Menu > Import > Import Vectors.

You can also drag and drop .SKP files directly from a Windows folder into the 2D Drawing window to begin the vector import process.

As most components want to be cut so that the largest face is face up on the CNC router, if this option is selected, all the components in your SketchUp file will be rotated so that the face facing up is the largest.

If your design requires thin pieces that have a thicker profile then face, this option may not be suitable. Position your components within SketchUp with the correct orientation for cutting before importing.

If you are finding that your top face is not being used as the top face by the SketchUp Importer, (due to having a smaller surface area then the bottom face) then you can force it to stay the right way up by adding a colour to the top face in SketchUp.

Then when you are importing the vectors into Aspire/VCarve you can change the orientation option to "Orientate by Material" and pick your colour from the dropdown menu. This will inform the importer exactly which way up you need the model be.

To recognise the model’s parts as possible panels to create vectors from, a SketchUp model needs to be modelled as individual components, rather than the entire design constructed as one piece.

Break the design apart into its individual component parts within SketchUp and reimport it.

Your model has a hole in it from when it was saved in SketchUp, reopen it in SketchUp and use the drawing tools to cover the hole.

Check the face orientation to make sure the model is not inside out.

"Thanks for putting out your design videos. They are great inspiration for new users. I might have to get a laser for the OneFinity!"

Jeff Lynall